[Solved] Mailbox Cleanup Agent not working

Raise/discuss any potential issues with MailEnable for consideration in project issue register.
Post Reply
MartynK
Posts: 1364
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

[Solved] Mailbox Cleanup Agent not working

Post by MartynK » Thu Jun 11, 2015 4:18 am

I have switched on the mailbox cleanup agent on a few on my domains to delete old email from the junk folders after 7 days.

It does not seem to be deleting things as I have read and unread emails in the folder going back to 7th may.

Any ideas ?
Last edited by MartynK on Sat Jun 20, 2015 12:12 pm, edited 1 time in total.

MailEnable-Ian
Site Admin
Posts: 9247
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mailbox Cleanup Agent not working

Post by MailEnable-Ian » Mon Jun 15, 2015 1:44 am

Hi,

Check the "Management" services debug log file to see if there is log activity for when the cleanup agent is triggered. Do the .MAI files exist in the "Junk E-Mail" folder? Perhaps the message files were removed but a index update did not occur and thus the message details may still be present in the index file.
Regards,

Ian Margarone
MailEnable Support

MartynK
Posts: 1364
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

Re: Mailbox Cleanup Agent not working

Post by MartynK » Mon Jun 15, 2015 5:50 am

Hi,

I did not have that logging switched on, so I have done that now and will have to wait.

But looking in the folder, I can see all the emails there dating back to almost the start of May.

MailEnable-Ian
Site Admin
Posts: 9247
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mailbox Cleanup Agent not working

Post by MailEnable-Ian » Mon Jun 15, 2015 5:56 am

Hi,

Also check the polling interval for when the agent will execute. Click the "management" node in the administration console and in the right hand pane double click the mailbox cleanup agent. Check the poll interval. Default is every 7 days if you enabled the agent a few days ago it may have not yet triggered.
Regards,

Ian Margarone
MailEnable Support

MartynK
Posts: 1364
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

Re: Mailbox Cleanup Agent not working

Post by MartynK » Mon Jun 15, 2015 6:40 am

Yes, its 7 days, but its been enabled now for a good few months.

MailEnable-Ian
Site Admin
Posts: 9247
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mailbox Cleanup Agent not working

Post by MailEnable-Ian » Mon Jun 15, 2015 6:44 am

Hi,

Ok try lower the polling interval to 5 mins then check the log files to see if it executes or logs activity. Remember to increase the polling interval once tested.
Regards,

Ian Margarone
MailEnable Support

MartynK
Posts: 1364
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

Re: Mailbox Cleanup Agent not working

Post by MartynK » Tue Jun 16, 2015 2:03 am

Just looking for the polling interval, I cannot find it.

You say "management" node, you mean the management service ?

When I open the property page on that, its on got an Agents tab for remote administration.

MailEnable-Ian
Site Admin
Posts: 9247
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mailbox Cleanup Agent not working

Post by MailEnable-Ian » Tue Jun 16, 2015 2:34 am

Hi,
in the right hand pane double click the mailbox cleanup agent.
Regards,

Ian Margarone
MailEnable Support

MartynK
Posts: 1364
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

Re: Mailbox Cleanup Agent not working

Post by MartynK » Tue Jun 16, 2015 3:04 am

Ah yes, blond moment !!

OK, done that, it ran and cleaned up all the junk and deleted items.

So I have now put it to 1440 so it runs daily, lets see what happens.

MartynK
Posts: 1364
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

[Solved] Mailbox Cleanup Agent not working

Post by MartynK » Sat Jun 20, 2015 12:12 pm

it seems the agent was not working, but changing the pooling interval down, letting the agent run and then resetting it to the original value now works.

Post Reply