User not local; please try <forward-path> 47 33

Discussion regarding the Standard version.
Post Reply
Guest

User not local; please try <forward-path> 47 33

Post by Guest » Sat Jun 29, 2002 3:56 pm

Does any one has any idea about this!

I cannot send email to any email address which is not local. The following message is logged in the the Activity Logfile of SMTP (please note that forwarding feature works fine. I have configured the SMTP to forward all outgoing mails to a smart host):


06/28/02 21:18:48 SMTP-IN 596 24.191.89.107 220 svr01.mediopia.biz ESMTP Mail Enable SMTP Service, Version: 1.0.0.2 ready at Sat, 29 Jun 2002 01:18:48 -05:00 0 0
06/28/02 21:18:48 SMTP-IN 596 24.191.89.107 HELO HELO ns1 250 Requested mail action okay, completed 43 10
06/28/02 21:18:48 SMTP-IN 596 24.191.89.107 MAIL MAIL FROM: <mr@mediopia.biz> 250 Requested mail action okay, completed 43 30
06/28/02 21:18:48 SMTP-IN 596 24.191.89.107 RCPT RCPT TO: <syedmeesam@yahoo.com> 551 User not local; please try <forward-path> 47 33
06/28/02 21:18:48 SMTP-IN 596 24.191.89.107 QUIT QUIT 221 Service closing transmission channel 42 6

I will greatly appreciate a helpful reply,

Regards,
Razvi.

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Sat Jun 29, 2002 5:37 pm

Razvi,

Most likely - Your relay options or mail client settings are not set correctly.

In order to send mail to a domain that is not hosted under your server, mail clients will need to authenticate or be within a defined IP address range (there are more options here). This is to stop unknown parties from using your server to distribute mail (eg: SPAM).

The most likely solution to this is to ensure that you have the setting "Allow Relay for Authenticated Users" enabled on the SMTP Connector and that your mail client option "My Server Requires Authentication" is set.

When your clients attempt to send mail, they will authenticate and the server will allow them to send mail to remote domains (eg: yahoo - as in your example).

There is more information available at www.mailenable.com/kb.
Search for Relay Options.

Cheers

Fishyhead
Posts: 5
Joined: Sun Aug 04, 2002 10:22 am

Post by Fishyhead » Sun Aug 04, 2002 11:12 am

I seem to be having the same issue.

ME is set to Relay Authenticated Users and Outlook has the "Outbound Server Requires..." set.

Here's the e-mail I get when trying to mail outside my domain:

Your message did not reach some or all of the intended recipients.

Subject: Testing Outbound SMTP
Sent: 8/3/2002 2:10 PM

The following recipient(s) could not be reached:

'support@mailenable.com' on 8/3/2002 2:10 PM
551 User not local; please try <forward-path>

And the Activity Log Entry

08/03/02 14:00:42 SMTP-IN 416 66.75.124.160 220 v-co.net ESMTP Mail Enable SMTP Service, Version: 1.5015-- ready at Sat, 03 Aug 2002 21:00:42 +-0700 0 0
08/03/02 14:00:43 SMTP-IN 416 66.75.124.160 UNKN XXXX g3sg1 503 Bad sequence of commands 30 12
08/03/02 14:00:43 SMTP-IN 416 66.75.124.160 HELO HELO g3sg1 250 Requested mail action okay, completed 43 12
08/03/02 14:00:43 SMTP-IN 416 66.75.124.160 MAIL MAIL FROM: <Duy@ConceptualFinance.com> 250 Requested mail action okay, completed 43 40
08/03/02 14:00:43 SMTP-IN 416 66.75.124.160 RCPT RCPT TO: <support@mailenable.com> 551 User not local; please try <forward-path> 47 35
08/03/02 14:00:46 SMTP-IN 416 66.75.124.160 QUIT QUIT 221 Service closing transmission channel 42 6

I thought it should be an SMTP Out request instead of an SMTP-IN.

TIA

Duy

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Sun Aug 04, 2002 8:44 pm

The SMTP-IN indicates that this session is most likely being conducted between your mail client (eg: Outlook Express) and the MailEnable server.

When you are attempting to send mail to an external mail user (which in this case is support@mailenable.com) you are effectively relaying mail through the server. This needs to be controlled so that unauthorised people cannot relay through your server (and use it for spam).

As a result, there are relay options that can determine exactly who is allowed to relay through the server. The 551 Error inicates that you are not able to relay because you do not meet one or more of the criteria. From the transcript it appears that you have not authenticated against the SMTP Server (and this is most likely why it is not allowing you to send mail through the server).

You need to review your relay settings and make sure that you have your mail client configured appropriately. A good starting point is to ensure that you have authentication enabled on the mail client itself.

Cheers,
Regards, Andrew

Fishyhead
Posts: 5
Joined: Sun Aug 04, 2002 10:22 am

Post by Fishyhead » Sun Aug 04, 2002 10:48 pm

The Relay setting on the server is set to allow relay for authenticated users authenticating against the ME user database.

I'm using Outlook 2002 and I have it set to authenticate for outbound mail using the same settings as the inbound server (same username and password). I am able to receive mail perfectly.

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Mon Aug 05, 2002 1:53 am

This thead is a little confusing because there are two problems in this thread are the result of different issues.

Razvi: Need to know whether you are forwarding all mail from another mail server to mailenable or from mailenable to another mail server. I will assume that you are smarthosting another mailserver to MailEnable (becase of the fact that it seems from your logs that another server is initiating the relay attempt against your mailenable server).

If you are attempting to relay from a mail server through mailenable using smarthosting, you need to grant relay access to the server under a privileged IP range within mailenable. This is so MailEnable knows that it can relay mail that has been delivered to it from this host.

(There are other options whereby passwords can be exchanged between the two servers, but granting access to the relay requesting server's IP is the simplest way to accomodate this).


Fishyhead:

Your problem is caused because there is no AUTHentication being performed before you attempt to relay. Hence it returnes the 5XX error telling you cannot relay.

The most likely reason is because the EHLO command is not enabled on the SMTP Connector.

The line:
08/03/02 14:00:43 SMTP-IN 416 66.75.124.160 UNKN XXXX g3sg1 503 Bad sequence of commands 30 12
indicates that the server is unable to process a command (you have perhaps disabled one or more of the SMTP Commands under Advanced SMTP under the properties of the SMTP Connector. Check to make sure either the EHLO and AUTH Commands are checked under the Allowed SMTP Commands.


Hope this helps - Dave
Regards, Andrew

Fishyhead
Posts: 5
Joined: Sun Aug 04, 2002 10:22 am

Post by Fishyhead » Mon Aug 05, 2002 8:56 am

Most forums are happy that someone would use the search feature before posting.

I took screenshots of the SMTP properties. Smarthost is off so I did not include those pictures. I changed nothing for the logging tab as well.

http://www.conceptualfinance.com/smtp/SMTP_001.jpg
http://www.conceptualfinance.com/smtp/SMTP_002.jpg
http://www.conceptualfinance.com/smtp/SMTP_003.jpg
http://www.conceptualfinance.com/smtp/SMTP_004.jpg
http://www.conceptualfinance.com/smtp/SMTP_005.jpg

I also took shots of the client settings:
http://www.conceptualfinance.com/smtp/OL2002_001.jpg
http://www.conceptualfinance.com/smtp/OL2002_002.jpg
http://www.conceptualfinance.com/smtp/OL2002_003.jpg

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Mon Aug 05, 2002 2:22 pm

Hey,

I am thankful for the post - I was just pointing the thread streams for the benefit of forum not to the posters. Your forum eticate is exellent!

I am looking into the relay problem - I am suprised that the server does not accomodate the EHLO problem - this is something we have not seen before.

If you have another e-mail account I can use, pls mail it to support@mailenable.com. We will resolve off line and I will post the resolution to the forum.
Regards, Andrew

Fishyhead
Posts: 5
Joined: Sun Aug 04, 2002 10:22 am

Post by Fishyhead » Mon Aug 05, 2002 8:17 pm

Thank you for your time in looking to solve the problem to an application I downloaded for free. I am truely greatful for that.

If it helps, I am using Windows2000 Server with Service Pack3 though the problem existed in SP2 as well.

hindc
Posts: 2
Joined: Tue Aug 06, 2002 5:20 am
Location: Durban, South Africa

Post by hindc » Tue Aug 06, 2002 5:26 am

Hi,

I'm also having the exact same problem as Fishyhead. I'm also running W2K Server but with SP2.

I'm also using Outlook Express 5, and also authenticating against the ME userbase.

Thanks
Craig

hindc
Posts: 2
Joined: Tue Aug 06, 2002 5:20 am
Location: Durban, South Africa

Post by hindc » Tue Aug 06, 2002 5:58 am

belay that order captain...

I was using build 1.5006, and I upgraded to the latest download on the download page 1.5014 I think, and it fixes this problem.

No worries.

- Craig

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Tue Aug 06, 2002 6:13 am

Craig, you had me worried - Fishyhead's problem has me on my ear!

Fishyhead,

I am sorry to put you through all this, but it is a little hard to debug this without knowing exactly what the mail client is sending to the server. To establish this, enable Mail Conversation logging in Outlook Express.

1. Enable Client Side Logging for Outlook Express. Client side logging can be enabled in Outlook Express under (Tools->Options..|Maintenance, check Mail checkbox).

2. Attempt to send mail just as you have before.

3. Search your C: for a file called Smtp.log

4. Have a look at which corresponding command is being sent and misintepretted/misrepresented to the server (We are after the line that matches the UNKN indicated in your logs.

Send this log to Support@mailenable.com and we will have a look at it for you.

In summary, what appears to be happening is that the EHLO is not being received correctly by the server (please ensure that you are not running through a firewall that modifies extended SMTP Commands).

As a result of the failed EHLO, the client is not able to receive the list of SMTP Extensions offered by MailEnable and therefore, the client does not know that it can send the AUTH command to perform authentication against the server. - As a result, the relay attempt is denied when the RCPT command is issued. So the solution lies in working out why the AUTH command is not arriving or being processed by the server correctly.

To make things a little more obscure, one of the production test servers runs the precise configuration you outline and it hosts hundreds of subscribers (of which I am one!). I am using Outlook Express 5. If you send the logs to the e-mail address outlined it would be much appreciated.
Regards, Andrew

Fishyhead
Posts: 5
Joined: Sun Aug 04, 2002 10:22 am

Post by Fishyhead » Tue Aug 06, 2002 6:22 pm

support wrote:(please ensure that you are not running through a firewall that modifies extended SMTP Commands).
Ahh, this gave me a hint.

I'm using a Cisco PIX firewall on these servers. The Mail Guard feature only allows the following SMTP commands: HELO, MAIL, RCPT, DATA, RSET, NOOP, and QUIT.

To disabled Mail Guard on the PIX, I used the following command:
no fixup protocol smtp 25

It's all fixed. You may want to add this article into your FAQ for other PIX users.

Thanks again for your help!

Post Reply