MailEnable SMTP Smart Host to Exchange Online

Discussions on webmail and the Professional version.
Post Reply
mike2k
Posts: 1
Joined: Thu Feb 25, 2021 12:20 pm

MailEnable SMTP Smart Host to Exchange Online

Post by mike2k » Thu Feb 25, 2021 12:50 pm

Hello all,
following setup: Mail domain cudo.com is running on a mailEnable Windows server.
Now there is an additional Microsoft O365 environment with Exchnage Online and the domain cudo.com is enabled there.
There is a guide from Microsoft that describes which connectors to set up:
https://docs.microsoft.com/de-de/exchange/mail-flow-best-practices/use-connectors-to-configure-mail-flow/set-up-connectors-to-route-mail
I want ALL emails to be sent only through Exchange Online.
The connector "from exchange online to mailEnable" works fine, i.e. when I send an email to a mailEnable mailbox, Exchange Online successfully passes the message to mailEnable.
But what does not work is sending mailEnable via Exchange Online.
I have already tried to change the SMTP settings to enable Smart Host and forward everything to smtp.office365.com.
Unfortunately, I keep getting as response to emails sent:
Reason: 530 5.7.57 Client not authenticated to send mail. [AM6PR05CA0027.eurprd05.prod.outlook.com]
Can anyone help me who has successfully set up this setup before?
Many thanks and best regards


Here are some logs:

Code: Select all

02/25/21 12:47:48	ME-I0018: [B216839EF56D4C088341FE137D8B6BEE.MAI] Outbound message from ([SMTP:J.Doe@cudo.com]) requeued as [B1B0615DC08A47668ABA5C98E77C615F.MAI] to the target domain [yahoo.com]
02/25/21 12:47:48	ME-I0122: [B1B0615DC08A47668ABA5C98E77C615F.MAI] SMTP Server is forwarding all mail (directly) to SMTP Hosts [smtp.office365.com].
02/25/21 12:47:48	ME-I0026: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Sending message
02/25/21 12:47:48	ME-IXXXX: [B1B0615DC08A47668ABA5C98E77C615F.MAI] DNS resolved to the following record: IP Address=XX.XX.XXX.XX, Family=2, Type=1, Protocol=6
02/25/21 12:47:48	ME-IXXXX: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Failed to set up outbound SSL environment.
02/25/21 12:47:48	ME-I0074: [1148] (Debug) End of conversation
02/25/21 12:47:49	ME-I0074: [1156] (Debug) End of conversation
02/25/21 12:47:53	ME-IXXXX: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Remote server returned a response indicating a permanent error. Server Response: (530 5.7.57 Client not authenticated to send mail. [AM6XXXXXXXXX.eurprd02.prod.outlook.com]**)
02/25/21 12:47:53	ME-E0036: [B1B0615DC08A47668ABA5C98E77C615F.MAI] MAIL FROM command Failed.
02/25/21 12:47:53	SSL recv failed: socket has was closed gracefully by peer before this recv [1228]
02/25/21 12:47:53	ME-I0009: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Remote server has closed connection after 0 milliseconds. Server Response: (-)
02/25/21 12:47:53	[0] Send failed (error 10038). Size 6
02/25/21 12:47:53	ME-E0008: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Outbound, could not send the command to the server (error 10038).
02/25/21 12:47:53	ME-E0060: [B1B0615DC08A47668ABA5C98E77C615F.MAI] - Message could not be delivered to target domain (yahoo.com). Message returned to Sender.
02/25/21 12:47:53	ME-I0119: Domain [cudo.com] has used local loopback address [127.0.0.1] because it is hosted locally.
02/25/21 12:47:53	ME-I0026: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Sending message
02/25/21 12:47:53	ME-IXXXX: [B1B0615DC08A47668ABA5C98E77C615F.MAI] DNS resolved to the following record: IP Address=127.0.0.1, Family=2, Type=1, Protocol=0
02/25/21 12:47:53	[976] Successfully started inbound SSL conversation
02/25/21 12:47:53	ME-IXXXX: [B1B0615DC08A47668ABA5C98E77C615F.MAI] Failed to set up outbound SSL environment.

Last edited by mike2k on Fri Feb 26, 2021 8:02 am, edited 1 time in total.

MailEnable-Ian
Site Admin
Posts: 9372
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: MailEnable SMTP Smart Host to Exchange Online

Post by MailEnable-Ian » Thu Feb 25, 2021 10:50 pm

Hi,

Have you reviewed this Microsoft post?

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_outlook-mso_winother-mso_o365b/client-was-not-authenticated-to-send-anonymous/d405bcb0-f40c-42fa-b1b2-477597100123
Regards,

Ian Margarone
MailEnable Support

Post Reply