anyone get this to work?

Discussions on webmail and the Professional version.
kruger@sanarchitect.net

anyone get this to work?

Post by kruger@sanarchitect.net » Wed Jun 12, 2002 6:18 am

it seems like there is no instructions as to how to get
the webmail to install and work..
I managed to find a folder where all the files were located
and I configured IIS to point to these files
but the login wasnt working
and no where in the documentation is how to get it to work??>>>
am I missing something>>.

Peter

Post by Peter » Wed Jun 12, 2002 2:57 pm

When you install the webmail, it creates a virtual directory called mewebmail in your default web site. You can then access the site by using:

http://machinename/mewebmail

The virtual directory points to the Mail Enable\bin\webmail directory. If you pointed you site to the files, it won't work unless you create a virtual directory called mewebmail (the app looks for /mewebmail). Check IIS and see if a virtual directory was created in your default web site.

Jason

Got it to work on 2000 Professional

Post by Jason » Fri Jun 14, 2002 2:42 am

I got it to work on 2000 -- and didn't have to jump through many hoops. Trying to run it on XP Professional is another story... still don't have it working.

kruger@sanarchitect.net

already did that

Post by kruger@sanarchitect.net » Fri Jun 14, 2002 6:09 am

I created a virtual directory in iis
so it would act like this www.noname.com/mewebmail
and thats how i got the login window..
but i could not get the mail login to work...

Scott
Posts: 6
Joined: Fri Jun 14, 2002 8:10 am

Mail Logon

Post by Scott » Fri Jun 14, 2002 8:23 am

When you logon using webmail, make sure you use the mailbox name@domain as the username and not just the mailbox name:

Username: name@domain.com
Password: ********

Admin
Site Admin
Posts: 825
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Post by Admin » Fri Jun 14, 2002 5:05 pm

The login name is mailboxname@postofficename (since the post office name can be different from the domain).

You can use just the mailboxname if you specify a default post office in the Administration program (expand the Servers branch, right click on localhost icon and select Properties from the popup menu).

Guest

Re: Mail Logon

Post by Guest » Tue Jun 18, 2002 3:21 pm

Scott wrote:When you logon using webmail, make sure you use the mailbox name@domain as the username and not just the mailbox name:

Username: name@domain.com
Password: ********
What about mulitple domains... I want the users to only use there screennames..

Admin
Site Admin
Posts: 825
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Post by Admin » Tue Jun 18, 2002 4:21 pm

You'd have to put all the mailboxes and domains under the one post office and have this post office set at the default if you don't want the @postofficename part of the username to be needed.

It's done like this so you can have the same named mailbox in different post offices.

Guest

Post by Guest » Thu Jun 27, 2002 9:02 pm

Peter wrote:When you install the webmail, it creates a virtual directory called mewebmail in your default web site. You can then access the site by using:

http://machinename/mewebmail

The virtual directory points to the Mail Enable\bin\webmail directory. If you pointed you site to the files, it won't work unless you create a virtual directory called mewebmail (the app looks for /mewebmail). Check IIS and see if a virtual directory was created in your default web site.


Help please
virtual directory wont create what can i do?????

Admin
Site Admin
Posts: 825
Joined: Mon Jun 10, 2002 6:31 pm
Location: Melbourne, Victoria, Australia

Post by Admin » Fri Jun 28, 2002 6:55 am

Ideally we would of course like to know why the virtual directory is not being created. However, we can create the virtual directory manually to determine if this is the only problem incurred during the installation.

1. From the desktop right click on My Computer and select Manage.

2. Expand Computer Management\System Tools\Local Users and Groups and right click on the User IME_USER and reset the password for this account. (The account is created both by Standard and Pro versions so it should be there).

3. Open the Internet Service Manager from (Start|Programs|Administrative Tools)

4. Select the Default Web Site and Right Click, selecting New|Virtual Directory. Use the wizard (if running 2K) and enter the Alias as MEWebMail. Click Next

5. Use the browse button to select your C:\Program Files\Mail Enable\Bin\WebMail directory. Click Next

6. Accept the default Access Permissions for the Virtual Directory (Read, Run Scripts) Click Next to Finish the Wizard.

7. Right Click on the MEWebMail Virtual Directory (which should now appear in your list) and Select the Directory Security tab.

8. Select Edit for Anonymous Access and authentication control

9. Ensure that anonymous access is checked (it will be by default) and Click on the corresponding Edit button

10. Enter the IME_USER as the username with the password you set earlier

11. Ensure that you check the Allow IIS to control password option

12. Click OK to close all open windows (there should be 3 of them).

13. Using the web browser on the server, enter http://127.0.0.1/MEWebmail

If this does not work then it is likely that there are other issues that are causing the install to fail (like insufficient priv when running the install).

I hope this helps and I applogise for the complexity associated with performing the procedure.

Cheers

coolpup32
Posts: 89
Joined: Wed Jun 12, 2002 3:11 pm
Contact:

virtual directory

Post by coolpup32 » Fri Jun 28, 2002 3:58 pm

what is the IME_user password supposed to be.. what we made the postoffice password or leave it blank?
I just reformatted my computer. My computer isnt creating a virtual directory either. :cry:

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Fri Jun 28, 2002 10:14 pm

You can set the IME_USER password to whatever you want. IME_USER is a configuration account not used within ME other than as a proxy account for IIS. You probably dont even need to remember it yourself other than to enter it in the dialog within IIS in Step 10.

Also, make sure you set the password expiration option to never expire.

vnvjeep
Posts: 88
Joined: Tue Jun 25, 2002 3:01 pm
Location: Orlando, FL

virtual directory

Post by vnvjeep » Sat Jun 29, 2002 1:34 am

Hi Peter...

Just wanted to let you know that when I installed Pro, the virtual directory didn't get installed. It created the IME_USER & IME_ADMIN accounts just fine, but never the virtual. I ended up creating it myself, but didn't know one of these user accounts were supposed to be associated with it... No wonder I was running into so many permissions issues! :)

Take care,
Mike

coolpup32
Posts: 89
Joined: Wed Jun 12, 2002 3:11 pm
Contact:

virtual directory

Post by coolpup32 » Mon Jul 01, 2002 4:49 pm

hey, I'm on my second format this week. Virtual directory still didnt create. I think its the newer versions. unless it wont create with active directory installed !?
I'm having trouble with my domain controller anyone want to help! :twisted:

MailEnable
Site Admin
Posts: 4441
Joined: Tue Jun 25, 2002 3:03 am
Location: Melbourne, Victoria Australia

Post by MailEnable » Tue Jul 02, 2002 4:38 am

coolpup, vnvjeep

just to clarify what the IME_USER and IME_ADMIN accounts are used for.

IME_USER is used as an account for the security context for the /MEWebmail directory application (and in future, the /MEWebAdmin directory). This account is used as an alternative to the IUSR_MACHINENAME account (to provide a more secure context for the MailEnable IIS web applications).

The IME_ADMIN account is used as a proxy account for MTS/COM+, as this account needs access to virtually everything ranging from the CONFIG directory to individual mailboxes.

In previous betas of Professional, there have been issues with the creation and access to the virtual directories that are created by the MailEnable's installation. These issues should now be resolved in the now current release.

Cheers,

Dave

Post Reply