wilcard SSL

Discussion forum for Enterprise Edition.
Post Reply
aremdee
Posts: 59
Joined: Mon Oct 08, 2007 9:56 pm
Location: Victoria, Australia

wilcard SSL

Post by aremdee » Fri Jun 12, 2015 3:25 am

I have a wildcard SSL certificate installed on the server and have enabled SSL under Server>locahost>properties>SSL. Despite this I can't seemed to connect securely as I thought would be the case. I've googled and come across a Mailenable help topic that talks of giving IME_SYSTEM user full permission on the certificate. This is all well and good but I don't have an IME_SYSTEM user on the server. Have IME_ADMIN and IME_USER. Just wondering if I need to substitute one of these for the one mentioned in the help topic to make it work?

Thanks
Roger

MartynK
Posts: 1369
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

Re: wilcard SSL

Post by MartynK » Fri Jun 12, 2015 4:25 am

When you say you have enabled the certificate, under what settings exactly ?

If you want this for your webmail and webamin pages, you need to do it in the IIS Bindings for the web sites.

You only need to do the permissioning if your using EAS from memory.

I personally do the following:
1. Create a HTTPS webmail site on IP xxx.1 and bind the SSL giving to a address like wmailcore.ssldomain.com
2. Create a HTTPS webadmin site on IP xxx.2 and bind the SSL giving to a address like wadmincore.ssldomain.com
3. Create a generic HTTP site which has a redirect to my HTTPS webmail site from webmail.anydomain.com
4. Create a generic HTTP site which has a redirect to my HTTPS webadmin site from webadmin.anydomain.com

This allows me to host multiple sites where each domain as its own webmail and webadmin URL but they all get redirected the the core domain that has the single SSL Cert, this keeps the costs down big time.

aremdee
Posts: 59
Joined: Mon Oct 08, 2007 9:56 pm
Location: Victoria, Australia

Re: wildcard SSL

Post by aremdee » Fri Jun 12, 2015 4:56 am

Thanks, but what I'm trying to achieve is a secure connection from the email client to the server. To do this I remote into the server, open Mailenable management console then under server right click localhost and then select properties and then SSL. According to the manual this should enable secure connections for POP3, IMAP etc via the domain that uses the wildcard certificate. But it doesn't though and that's my dilemma unless I'm missing something.

Thanks anyway for your help.
Roger

MartynK
Posts: 1369
Joined: Sat Dec 28, 2002 1:12 am
Location: Hong Kong

Re: wilcard SSL

Post by MartynK » Sat Jun 13, 2015 4:21 am

Under your SMTP settings, have you going in to the inbound property page and the "Port Settings" button, you need to enable the SMTP service to listen on the required SSL ports.

You also need to do this for your other protocols like IMAP and POP

Post Reply