Webmail not working after 9.1 upgrade

Discussion forum for Enterprise Edition.
Post Reply
dafacct
Posts: 22
Joined: Wed Aug 29, 2007 4:54 pm

Webmail not working after 9.1 upgrade

Post by dafacct » Fri Apr 01, 2016 2:54 pm

In addition to the mobile issue (that was resolved by a post from admin), we just noticed that "webmail" is not functioning. All users are getting a "runtime error"......Server Error in '/' Application. Help!!

Server Error in '/' Application.
Runtime Error
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>
Last edited by dafacct on Mon Apr 04, 2016 9:31 pm, edited 1 time in total.

dafacct
Posts: 22
Joined: Wed Aug 29, 2007 4:54 pm

Re: Webmail not working after 9.1 upgrade

Post by dafacct » Mon Apr 04, 2016 3:22 pm

Mailenable Tech Support........any ideas? How do I fix this?
Last edited by dafacct on Mon Apr 04, 2016 9:36 pm, edited 1 time in total.

dafacct
Posts: 22
Joined: Wed Aug 29, 2007 4:54 pm

Re: Webmail not working after 9.1 upgrade

Post by dafacct » Mon Apr 04, 2016 6:53 pm

TECH SUPPORT!!!!!! PLEASE REPLY!!!! I've reinstalled the 9.1 update.......again, and still get the webmail errors. We DID NOT have errors prior to installing 9.1. PLEASE!!!!!

MailEnable-Ian
Site Admin
Posts: 9101
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Webmail not working after 9.1 upgrade

Post by MailEnable-Ian » Tue Apr 05, 2016 2:50 am

Hi,

For urgent assistance you should really lodge a support ticket via our support ticketing system under the category of "Upgrade" for a managed response.

https://www.mailenable.com/support/step1.asp

For your problems with web mail try the following:

1. Navigate within the MailEnable installation folder to: Mail Enable\BIN.
2. Locate the "meinstaller.exe" file and right click and select "Run as Administrator", if available.
3. In the "MailEnable System Configuration Utility" options window click on option 2: "Web Mail Installation / Reconfiguration (File Perms, User Rights, COM+, IIS Proxy User, etc.) and then click the "Execute" button.
4. When prompted by the utility specify a complex password that will be used for MailEnable service accounts (remember the password as it will need to be used in the next step) and click "OK".
5. Next click on option 3: WebAdmin Installation / Reconfiguration (File Perms, User Rights, COM+, IIS Proxy User, etc.) and then click "Execute".
6. When prompted by the utility use the same password in step 4.
7. Once the utility has completed open up a browser and try to access the web mail and web administration interfaces to see if the error has been rectified.
Regards,

Ian Margarone
MailEnable Support

dafacct
Posts: 22
Joined: Wed Aug 29, 2007 4:54 pm

Re: Webmail not working after 9.1 upgrade

Post by dafacct » Tue Apr 05, 2016 1:56 pm

Thanks for the reply. I ran the procedure exactly as instructed, but still get the error for all webmail clients.

georgec
Posts: 5
Joined: Tue Oct 13, 2015 6:41 am

Re: Webmail not working after 9.1 upgrade

Post by georgec » Wed Apr 06, 2016 11:04 am

Hello,

I am having the exact same issue.

Updated to 9.11 today and i can log in to webmail though everytime i click on an email i get an error. Below is the full error when accessed from the server. I also followed all above procedures you mentioned with no luck.

I also tried changing ASP version from 4 to 2 with the "Set .NET version" option in the meinstaller, with no luck.

Code: Select all

C:\Windows\SysWOW64\inetsrv> "C:\Windows\Microsoft.NET\Framework\v4.0.30319\vbc.exe" /t:library /utf8output /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\83f5f286\00c694bc_8a4acb01\Keyoti.RapidSpellWeb.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\c8c55ee0\000e7d19_debccd01\FreeTextBox.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.WorkflowServices\v4.0_4.0.0.0__31bf3856ad364e35\System.WorkflowServices.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\3771c697\00391282_cb97cd01\HtmlAgilityPack.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Xml.Linq\v4.0_4.0.0.0__b77a5c561934e089\System.Xml.Linq.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\074953f4\00a60937_ca8fd101\MEWebmail.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\9fa8054e\0013f7ba_038cd101\ARPDev.Core.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.IdentityModel\v4.0_4.0.0.0__b77a5c561934e089\System.IdentityModel.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.Services\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Web.Services.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\00b4edc2\009963fb_d596cb01\Quickwebsoft.Web.UI.WebControls.EventCalendar.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ComponentModel.DataAnnotations\v4.0_4.0.0.0__31bf3856ad364e35\System.ComponentModel.DataAnnotations.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\003a6ffd\0030ea72_248fd101\MailEnable.MIME.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\7f1d26a3\00f2e733_e489cd01\Ionic.Zip.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\e7954e38\00d8ea49_6bb5d001\DNDNS.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\c62bd622\00c8cf1c_ca8fd101\MailEnable.Administration.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Runtime.Serialization\v4.0_4.0.0.0__b77a5c561934e089\System.Runtime.Serialization.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\2f85fd8d\00c694bc_8a4acb01\SPELLCHECKERSERVERLib.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.ApplicationServices\v4.0_4.0.0.0__31bf3856ad364e35\System.Web.ApplicationServices.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\App_Web_2nhdq2lf.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\0a5c8088\00954966_530dd101\MailEnable.Core.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ServiceModel.Web\v4.0_4.0.0.0__31bf3856ad364e35\System.ServiceModel.Web.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Drawing\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Drawing.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\Microsoft.CSharp\v4.0_4.0.0.0__b03f5f7f11d50a3a\Microsoft.CSharp.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\3b613f30\00c694bc_8a4acb01\Keyoti.RapidSpellMDict.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ServiceModel\v4.0_4.0.0.0__b77a5c561934e089\System.ServiceModel.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\6c5e3f18\00f55da7_fd84d101\ARPDev.Core.Helper.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\b94c4839\00413c19_ca8fd101\MailEnable.MailboxSearching.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\8e4998e2\00a60937_ca8fd101\HooDooWebMail.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Core\v4.0_4.0.0.0__b77a5c561934e089\System.Core.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ServiceModel.Activities\v4.0_4.0.0.0__31bf3856ad364e35\System.ServiceModel.Activities.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\56be7b30\00a60937_ca8fd101\NetWebMail.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\8f070d1d\008d7714_ca8fd101\MailEnable.Installation.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\0fe74d14\005d25da_6132cc01\log4net.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_32\System.Data\v4.0_4.0.0.0__b77a5c561934e089\System.Data.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_32\System.EnterpriseServices\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.EnterpriseServices.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\a1559c4d\00a60937_ca8fd101\MobileWebMail.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\0894c098\00413c19_ca8fd101\MailEnable.Migration.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.DynamicData\v4.0_4.0.0.0__31bf3856ad364e35\System.Web.DynamicData.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\3e522958\00e41d2b_ca8fd101\MailEnable.Web.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\App_global.asax.v4pd6vvl.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.ServiceModel.Activation\v4.0_4.0.0.0__31bf3856ad364e35\System.ServiceModel.Activation.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System\v4.0_4.0.0.0__b77a5c561934e089\System.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.Entity\v4.0_4.0.0.0__b77a5c561934e089\System.Web.Entity.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Activities\v4.0_4.0.0.0__31bf3856ad364e35\System.Activities.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Web.Extensions\v4.0_4.0.0.0__31bf3856ad364e35\System.Web.Extensions.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_32\System.Web\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Web.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Xml\v4.0_4.0.0.0__b77a5c561934e089\System.Xml.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\77c4fc27\00a60937_ca8fd101\MondoWebMail.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Data.DataSetExtensions\v4.0_4.0.0.0__b77a5c561934e089\System.Data.DataSetExtensions.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\da3e9164\00d0e29d_2ef1ce01\Lucene.Net.dll" /R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\assembly\dl3\35d2bba8\0022321f_ca8fd101\MailEnable.Store.dll" /R:"C:\Windows\Microsoft.Net\assembly\GAC_MSIL\System.Configuration\v4.0_4.0.0.0__b03f5f7f11d50a3a\System.Configuration.dll" /out:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\App_Web_read.aspx.4ae55e09.-wxziwzt.dll" /debug- /win32resource:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\p0j0kq0c.res" /nowarn:41008,40000,40008 /define:_MYTYPE=\"Web\" /imports:Microsoft.VisualBasic,System,System.Collections,System.Collections.Generic,System.Collections.Specialized,System.ComponentModel.DataAnnotations,System.Configuration,System.Linq,System.Text,System.Text.RegularExpressions,System.Web,System.Web.Caching,System.Web.DynamicData,System.Web.SessionState,System.Web.Security,System.Web.Profile,System.Web.UI,System.Web.UI.WebControls,System.Web.UI.WebControls.WebParts,System.Web.UI.HtmlControls,System.Xml.Linq /warnaserror- /optionInfer+  "C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\App_Web_read.aspx.4ae55e09.-wxziwzt.0.vb" "C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\App_Web_read.aspx.4ae55e09.-wxziwzt.1.vb"


Microsoft (R) Visual Basic Compiler version 12.0.51209.34209
Copyright (c) Microsoft Corporation.  All rights reserved.

C:\Program Files (x86)\Parallels\Plesk\Mail Servers\Mail Enable\Bin\NETWebMail\Mondo\lang\sys\Forms\MAI\read.aspx(908) : error BC30691: 'Licensing' is a type in 'MailEnable' and cannot be used as an expression.

                                       If (MailEnable.Administration.Licensing.GrantedLicense(MailEnable.Licensing,MailEnable.Administration.Licensing.gcMME_SERVICE_WEBMAIL_REPORTASSPAM) <> 0) And bMailboxMessageReportAsSpam Then
                                                                                              ~~~~~~~~~~~~~~~~~~~~                                                                                                                   
C:\Program Files (x86)\Parallels\Plesk\Mail Servers\Mail Enable\Bin\NETWebMail\Mondo\lang\sys\Forms\MAI\read.aspx(970) : error BC30691: 'Licensing' is a type in 'MailEnable' and cannot be used as an expression.

                                       If (MailEnable.Administration.Licensing.GrantedLicense(MailEnable.Licensing,MailEnable.Administration.Licensing.gcMME_SERVICE_WEBMAIL_REPORTASSPAM) <> 0) And bMailboxMessageReportAsSpam Then
                                                                                              ~~~~~~~~~~~~~~~~~~~~                                                                                                                   
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\root\c889f7b2\6d92e8da\App_Web_read.aspx.4ae55e09.-wxziwzt.0.vb(32) : warning BC40056: Namespace or type specified in the Imports 'System.Web.UI.Controls' doesn't contain any public member or cannot be found. Make sure the namespace or the type is defined and contains at least one public member. Make sure the imported element name doesn't use any aliases.

Imports System.Web.UI.Controls
        ~~~~~~~~~~~~~~~~~~~~~~
Please provide a fix as soon as possible.

UPDATE: I have just noticed something. When accessing webmail through a browser, if i select Mobile Version, the webmail works fine and emails are opened correctly. So it seems the issue is only with the Desktop Version.
Last edited by georgec on Wed Apr 06, 2016 1:00 pm, edited 1 time in total.

Marlenio
Posts: 17
Joined: Tue Jun 01, 2004 6:52 pm

Re: Webmail not working after 9.1 upgrade

Post by Marlenio » Wed Apr 06, 2016 1:00 pm

Same error, Enterprise version. Back to 9.05.

MailEnable-Ian
Site Admin
Posts: 9101
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Webmail not working after 9.1 upgrade

Post by MailEnable-Ian » Thu Apr 07, 2016 2:17 am

Hi,

There problems in the first release of 9.11. Please download the 9.11 from the downloads page again as its a revised version which rectifies the problems in web mail your experiencing when opening messages in web mail.
Regards,

Ian Margarone
MailEnable Support

Post Reply