Webmail not showing sub-directories greater than 2 levels deep after update to 10.21

Discussion forum for Enterprise Edition.
Post Reply
PeteBatin
Posts: 21
Joined: Fri Jan 22, 2016 9:32 am

Webmail not showing sub-directories greater than 2 levels deep after update to 10.21

Post by PeteBatin » Thu Mar 21, 2019 4:55 pm

As the subject suggest, recently updated to 10.21 and now webmail will not show sub-directories greater than 2 levels deep. Physical files and directories are present in filesystem.

Tested on multiple mailboxes from different domains, same result. IMAP displays all directories without issue.

All services restarted and also restarted the machine, no effect.

Deleted _folder.xml and _index.xml so they were rebuilt, no effect (also even if it did work, not feasible with the amount of mailboxes and domains we host to do this for every folder)

Windows Server 2012.

Bug report submitted, raised here also.

PeteBatin
Posts: 21
Joined: Fri Jan 22, 2016 9:32 am

Re: Webmail not showing sub-directories greater than 2 levels deep after update to 10.21

Post by PeteBatin » Thu Mar 21, 2019 5:16 pm

If anyone else has this problem update to 10.22. Mailenable notified us of the release of 10.21 but not .22 which they released 2 days later but didn't tell anyone. Only realised myself out of curiosity!

10.22 20th March 2019
---------------------
FIX: Replaced Google QRCode render with embedded solution (Deprecated on 19th March)
FIX: Webmail folder list would not render entire depth of folder tree
IMP: Increased webmail index to allow storing additional properties (Categories/ Task Completion Date)
IMP: Improved initial render speed of login page

10.21 18th March 2019
---------------------
ADD: New greylisting option to bypass hosts with valid SPF...
....
...

Post Reply