Mailbox search indexing failing

Discussion forum for Enterprise Edition.
Post Reply
Brett Rowbotham
Posts: 542
Joined: Mon Nov 03, 2003 7:48 am
Location: Cape Town

Mailbox search indexing failing

Post by Brett Rowbotham » Wed Oct 16, 2019 4:08 am

The mailbox indexing service log starts with:

2019-10-16 05:39:58,100 [4] INFO - MailEnable Mailbox Search Indexing Service starting.
2019-10-16 05:39:58,241 [4] INFO - Started the initialisation processor.
2019-10-16 05:39:58,241 [4] INFO - Started the update processor.
2019-10-16 05:40:58,367 [6] INFO - 35 pending index updates.
2019-10-16 05:40:58,780 [6] ERROR - Encountered a problem while attempting to find an index update request: Root element is missing.
2019-10-16 05:41:59,456 [9] INFO - 35 pending index updates.
2019-10-16 05:41:59,456 [9] ERROR - Encountered a problem while attempting to find an index update request: Root element is missing.

and then the last two lines just keep on repeating for days.

Where do I look for the item causing this problem ?

MailEnable-Ian
Site Admin
Posts: 9162
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: Mailbox search indexing failing

Post by MailEnable-Ian » Thu Oct 17, 2019 4:48 am

Hi,

Looks like a corruption in the "VerificationState.xml" file for the indexing service. Navigate to: Mail Enable\Config\MailboxSearchIndexing folder. Delete the "VerificationState.xml" file and restart the indexing service.
Regards,

Ian Margarone
MailEnable Support

Brett Rowbotham
Posts: 542
Joined: Mon Nov 03, 2003 7:48 am
Location: Cape Town

Re: Mailbox search indexing failing

Post by Brett Rowbotham » Thu Oct 17, 2019 4:57 am

Thanks. The file was empty so I have deleted it and will see what happens next.

Brett Rowbotham
Posts: 542
Joined: Mon Nov 03, 2003 7:48 am
Location: Cape Town

Re: Mailbox search indexing failing

Post by Brett Rowbotham » Tue Oct 22, 2019 3:57 am

Unfortunately, although indexing started again after deleting the empty xml file, a little while later there was an exception and indexing stopped again:

2019-10-17 08:12:15,682 [26] ERROR - Failed to update index for andrew@KnowBase: background merge hit exception: _szq:C8676 _t0y:c1 _t11:c2->_t11 _t13:c6->_t13 _t15:c33->_t15 _t17:c8->_t17 _t1a:c2->_t1a _t1c:c19->_t1c into _t1e [optimize] [mergeDocStores].

Post Reply