Uploading attachments larger than 10000KB fails through web mail


SYMPTOMS

Uploading large attachments fails when using web mail.

CAUSE

By default both IIS and webmail will restrict the size of attachment uploads.

RESOLUTION

You can set the attachment upload limit by editing the web.config file for the webmail application. To do this navigate to the following location where you installed the software to:

Mail Enable\bin\NETwebmail\

Locate the file "web.config" and open it up in Notepad. Locate the following line in the file:

<httpRuntime maxRequestLength="10240" executionTimeout="3600" />

The value that needs to be changed is the maxRequestLength. This value is in KB.

If you are using IIS 7.0 or later (Windows 2008 and later), then you will also need to add the lines under the <system.webServer> section. So you need to add in this section:

<security>
  <requestFiltering>
    <requestLimits maxAllowedContentLength="10240000" />
  </requestFiltering>
</security>

The value for maxAllowedContentLength is in bytes, so it will be different to the maxRequestLength size.

MORE INFORMATION

If changing the value within the MailEnable "web.config" file does not resolve the uploading failure, then the next step would be to inspect the following Microsoft Knowledge Base article that explains how to edit the maxAllowedContentLength property in the ApplicationHost.config file. If there is a restriction server wide, then this would override your webmail settings.

http://support.microsoft.com/kb/942074

 



Product:MailEnable (ME-2.X Pro-2.X Ent-2.X)
Category:Other
Article:ME020445
Module:WebMail
Keywords:attachment,upload,.aspx,large,attachments,fails,size
Class:TRB: Troubleshooting (Configuration or Environment)
Revised:Thursday, February 23, 2017
Author:
Publisher:MailEnable