diagnostic says "no spf" record

Discussion regarding the Standard version.
Post Reply
HardDrive
Posts: 1
Joined: Sat Sep 12, 2020 10:49 pm

diagnostic says "no spf" record

Post by HardDrive » Sat Sep 12, 2020 11:00 pm

Hello,

This is a brand new install on Windows Server 2012. The diagnostic utility shows a warning ...

No SPF record found. You should consider creating an SPF record for MAIL.KLKriegel.com or change the SMTP Default Host name to a domain with an SPF record

I visited an spf checker websit and they verified my pf record ....

https://dmarcian.com/spf-survey/?domain=klkriegel.com


Any idea about why the diagnostic is failing ??

MailEnable-Ian
Site Admin
Posts: 9397
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: diagnostic says "no spf" record

Post by MailEnable-Ian » Mon Sep 14, 2020 12:36 am

Hi,

You need to change the SMTP default mail domain name to "klkriegel.com" and not "mail.klkriegel.com". The diagnostic report checks fro SPF on the SMTP default mail domain since some servers perform SPF checks on the default mail domain name (EHLO greeting).
Regards,

Ian Margarone
MailEnable Support

highdownts
Posts: 3
Joined: Mon Feb 05, 2018 9:17 pm

Re: diagnostic says "no spf" record

Post by highdownts » Mon Nov 09, 2020 11:57 pm

Are you referring to the SMTP properties dialog? If so, the dialog says to use mail.domain.com.

If this isn't the right dialog, can you please clarify. I have been unable to eliminate this SPF warning. Your feedback is much appreciated.

Thanks...

Post Reply