relay won't relay

Discussion regarding the Standard version.
Post Reply
tandersn
Posts: 3
Joined: Wed Mar 10, 2021 2:10 am

relay won't relay

Post by tandersn » Wed Mar 10, 2021 2:29 am

I am trying to set the relay enabled, and no matter how many boxes i check and how many times i restart the server, it won't relay.

This is on a private network, and the messages are from HW devices that only do basic port 25 smtp unauthenticated. The message needs to go out of the mail enable server to our ticketing queue, so an external address.

I have the "allow relay for privileged IP addresses" and have a list of ipaddress. It won't even work from 127.0.0.1 which is on the list.

Has this been intentionally disabled? Or am i completely missing something?

also, i can't search for the term "relay" because the forum search engine says it is too generic of a term.

MailEnable-Ian
Site Admin
Posts: 9397
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: relay won't relay

Post by MailEnable-Ian » Wed Mar 10, 2021 3:11 am

Hi,

Open the SMTP debug log file to see why the relay is being denied. If you are not authenticating then you need to relay by being granted relay rights as a privileged IP address. Ensure to add the IP address of where your sending from to the SMTP privileged IP's can relay list under the "deny all - except those in the list" option.
Regards,

Ian Margarone
MailEnable Support

tandersn
Posts: 3
Joined: Wed Mar 10, 2021 2:10 am

Re: relay won't relay

Post by tandersn » Wed Mar 10, 2021 3:48 am

Hello, that is exactly what i have done. See attached picture, but the log still says:
503 This mail server requires authentication when attempting to send to a non-local e-mail address.

I've tried directly from the localhost using 127.0.0.1 and from the remote host using
Attachments
mailenablerelay.PNG
mailenablerelay.PNG (25.48 KiB) Viewed 1263 times

MailEnable-Ian
Site Admin
Posts: 9397
Joined: Mon Mar 22, 2004 4:44 am
Location: Melbourne, Victoria, Australia

Re: relay won't relay

Post by MailEnable-Ian » Thu Mar 11, 2021 12:04 am

Hi,

Need access to the SMTP activity and debug log files. The SMTP debug will contain the reason/error as to why the relay was not granted.
Regards,

Ian Margarone
MailEnable Support

tandersn
Posts: 3
Joined: Wed Mar 10, 2021 2:10 am

Re: relay won't relay

Post by tandersn » Sat Mar 13, 2021 10:59 pm

Just to follow up,

For some reason, it just started working...

Thanks.

Post Reply