Filters > SPF Check Fail - Failing to work correctly

Discussion forum for Enterprise Edition.
Post Reply
PeteBatin
Posts: 22
Joined: Fri Jan 22, 2016 9:32 am

Filters > SPF Check Fail - Failing to work correctly

Post by PeteBatin » Thu Jul 01, 2021 11:30 am

We created a filter (Messaging Manager > Filters) with a name of "SPF Check - Fail" and the criteria of...

"Where the SPF test return results matching"
Enabled
SPF result matches: Fail.

With the actions:
Copy Message to Bad Mail,
Add a prefix to the subject of the message,
Delete Message

When looking at the logs (and this tends to be with MS Outlook mail)
06/30/21 16:47:27 ME-I0092: 40.107.10.126 is registered in the system whitelist and was therefore excluded from checking
06/30/21 16:47:30 Executed 7F11B6D5A04A43A48BA2145332CA1EE8.MAI SMTP SPF Check - Fail COPY_TO_BADMAIL,ADD_SUBJECT_PREFIX,DELETE [SMTP:user@domain.com] 40.107.10.126 CRITERIA=SPF, DATA=<MF-W>fail</MF-W>

The SPF rules for this domain are:

v=spf1 ip4:40.92.0.0/15 ip4:40.107.0.0/16 ip4:52.100.0.0/14 ip4:104.47.0.0/17 ip6:2a01:111:f400::/48 ip6:2a01:111:f403::/48 include:spfd.protection.outlook.com -all

The originating IP is valid/permitted under the SPF rules for the domain, it says immediately before getting a fail that it's in the system whitelist (they all seem to be in the whitelist some how?!) and excluded from checking. Then it fails the filter, how is this happening??

Also, is having the SPF Check Fail filter in Filters unnecessary due to having SPF checks enabled in SMTP properties?

Post Reply