Error "MEMTA.exe encountered a problem and needed to close" in my event log


SYMPTOMS

Error "MEMTA.exe encountered a problem and needed to close" in the event log

CAUSE

If the MTA is experiencing problems, then the cause is most likely a corrupt message command file in one of these directories:

C:\Program Files\Mail Enable\Queues\SMTP\Inbound
C:\Program Files\Mail Enable\Queues\SF\Inbound
C:\Program Files\Mail Enable\Queues\LS\Inbound
C:\Program Files\Mail Enable\Queues\POP\Inbound


The most likely location is the SMTP queue.

RESOLUTION

After locating the queue with the corrupted message, copy the files in this queue out of the directory and into a temporary directory. Then copy the files back in to the directory one by one until the MTA crashes. This will determine which message is corrupt.

The messages in this directory are the command files and are directive to the message files in the next folder down i.e. "Messages".  When feeding the files back into the queue as mentioned above, the delivery event will take the corresponding message from the "Messages" folder and send it. 

MORE INFORMATION

How to locate corrupt messages in the SMTP Connector Queues: http://www.mailenable.com/kb/content/article.asp?ID=ME020235


Product:MailEnable (All Versions)
Article:ME020260
Module:MTA
Keywords:MEMTA.exe,MTA,SMTP,corrupt,encountered,a,problem,and,needed,to,close,event,log
Class:ERR: Product Error
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable