Error "unable to open folder index" when accessing mailboxes via IMAP


NOTE:

This article is no longer applicable, as it only applies to version 3 and earlier of MailEnable.


SYMPTOMS

When using an IMAP client to select or open a folder the following error occurs:

BAD [READ-WRITE] SELECT unable to open folder index.

CAUSE

If the problem mentioned occurs on all mailboxes, the most likely cause is that the MSXML runtime is not installed or has issues.

RESOLUTION

Current versions of MailEnable use version 3 of MSXML. This can be addressed by (re) installing the runtime as at:

(Link no longer valid) http://www.microsoft.com/downloads/details.aspx?FamilyID=28494391-052b-42ff-9674-f752bdca9582&DisplayLang=en

The file to install is: msxml3usa.msi.

If the problem does not occur for all mailboxes, there must be an issue with the paths or permissions associated with that specific mailbox - in which case, Process Monitor (see: https://docs.microsoft.com/en-us/sysinternals/downloads/procmon) may assist in determining the cause of the problem.

MORE INFORMATION

Some messages may not appear in IMAP Message list when using Outlook Express: https://www.mailenable.com/kb/viewarticle.asp?&File=me020312.htm



Product:MailEnable (Pro-Any Pro-1.X Ent-Any Ent-1.X)
Article:ME020361
Module:IMAP
Keywords:imap,mailboxes,mailbox,bad,read,write,select,unable,to,open,folder,index,BAD,[READ-WRITE],SELECT,error,
Class:ERR: Product Error
Revised:Sunday, August 30, 2020
Author:
Publisher:MailEnable