SYMPTOMS
Antivirus scratch directory contains orphaned files
In most cases, there is a Knowledge Base article recommending the number of MTA transfer threads that should be used to avoid this problem, custom or third party scanners may have issues being run concurrently that are not likely to be documented in the Knowledge Base or by the vendor.
CAUSE
Some antivirus agents can have issues when called concurrently.
SOLUTION
As such,
those using antivirus scanners that have concurrency or orphaned process
issues
(i.e. if under task manager there are
instances of the anti-virus program still running) may want to consider
validating the process timeout (how long MailEnable will wait until it
terminates the command line scanner process).
This is done via the
following registry setting:
Key Root: SOFTWARE\Mail Enable\Mail
Enable\Agents\MTA\Filters
Key Name: Process Timeout
Key Value Type:
DWORD
Key Value Meaning: Time-out interval, in milliseconds. Value of
0xFFFFFFFF,
negative value or non existent key
= Wait Indefinitely
MORE INFORMATION
How to debug the antivirus support and the Mail Transfer Agent: http://www.mailenable.com/kb/content/article.asp?ID=ME020121
How does Antivirus Filtering work and how to configure it?: http://www.mailenable.com/kb/content/article.asp?ID=ME020056
Product: | MailEnable (Pro-Any Pro-1.X Ent-Any Ent-1.X) |
Article: | ME020362 |
Module: | MTA |
Keywords: | antivirus,anti,virus,av,anti-virus,scratch,directory,orphan,orphaned,files |
Class: | TIP: Product Tip |
Revised: | Wednesday, May 4, 2016 |
Author: | MailEnable |
Publisher: | MailEnable |