Outlook Rules are not executing if Microsoft Outlook is not running.


SYMPTOMS

Outlook Rules are not executing if Microsoft Outlook is not running.

CAUSE

When using Outlook Rules via the MailEnable MAPI connector, all rules will be treated as Client-side only rules. Client-side only rules will only execute if the Microsoft Outlook is opened.

A workaround for a server-side rules environment would be to use the mailbox filtering options within the MailEnable web mail interface to create a server-side rule that will execute if the Microsoft Outlook is not running.

Client-side Rules:

Example:

From flag message for

This rule will be a client-side only rule since the action is an Outlook feature and the MailEnable server therefore won't be able to process this rule. When Outlook is running or started again, the rule will be executed when the message is delivered to Outlook.

Client-side conditions/exceptions

Common conditions and exceptions that make a rule a client-only rule are;

* With specific words in the subject

* Marked as importance

* Marked as sensitivity

* Flagged for action

* With specific words in the body

* With specific words in the subject or body

* With specific words in the message header

* With specific words in the recipient's address

* With specific words in the sender's address

* Assigned to category

Client side actions

Common actions that make a rule a client-only rule are;

* Assign it to the category

* Permanently delete it

* Flag message for follow up at this time

* Clear the Message Flag

* Print it

* Mark it as read

* Display a specific message in the New Items Alert window

* Display a Desktop Alert



Product:MailEnable (Ent-Any)
Category:Environment
Article:ME020592
Module:MAPI
Keywords:rules,MAPI,Outlook,filter
Class:PRB: Product Problem or Issue
Revised:Wednesday, May 4, 2016
Author:
Publisher:MailEnable