Bounce messages are returning error "DNS lookup resulted in a loopback relay"


SYMPTOMS

Messages to some recipients are causing a bounce message with the error:

Reason: DNS lookup resulted in a loopback relay. This is not permitted and message has been returned. Please check recipient domain.

The SMTP Debug log will contain:

ME-F0000: [messageid] DNS Lookup resulted in a loopback relay. This is not permitted and message has been returned.

CAUSE

This is caused by the DNS records for the recipient domain indicating a local IP address for the destination, but the domain is not configured locally. For example, if a DNS entry for a domain says to deliver to 127.0.0.1, and the domain does not exist within the MailEnable configuration. This may cause a message loop, since relaying without authentication is normally allowed on local IP addresses. Since the message cannot be delivered, the email will bounce.

RESOLUTION

Sometimes people configure unused domains to return 127.0.0.1 and sometimes this is done to cause possible trouble. Otherwise it may be a DNS issue. Above the error in the SMTP Debug log look for a line similar to the one below that matches the recipient domain:

ME-I0123: Domain [example.com] has MX list [mail.example.com]

Make sure that the MX list results return valid IP addresses using nslookup. They should not return local IP addresses.

 



Product:MailEnable
Article:ME020677
Module:SMTP
Keywords:
Class:TRB: Troubleshooting (Configuration or Environment)
Revised:Thursday, January 4, 2018
Author:
Publisher:MailEnable