Unable to dispatch invitation notifications to remote XMPP users


SYMPTOMS

A chat invitation is dispatched to an external user and is not received.

The XMPP Debug log contains the following:

** Your server's relay settings do not permit directly sending invitations

CAUSE

If you receive the error: "Your server's relay settings do not permit directly sending invitations" then the XMPP service was not able to send/relay an invitation message to a remote user.

When the XMPP service attempts to dispatch the message, it will use the credentials of the currently logged in chat user to authenticate against the SMTP service by resolving localhost on port 25.

So, if you have allowed relay for authenticated users, the messages should be able to be dispatched to external parties. If this setting is not enabled for the SMTP connector, then you will need to grant the local IP address of the server relay rights.

RESOLUTION

The registry key controlling whether or not to use the logged in XMPP user's credentials for relay is:

HKLM::SOFTWARE\Mail Enable\Mail Enable\Services\XMPP\Use SMTP Authentication For Invitations (DWORD defaulting to 1).

You should not need to change this key, since it will relay using the logged in user's credentials by default. If you disable this key (by setting it to zero), then the service will attempt to relay without credentials (in which case you will need to have granted relay for the local IP address of the server).

To diagnose further, you should inspect the SMTP log files at the time that the message is being dispatched.

The log file should contain an entry indicating the connection and authentication attempt (as well as any relay refusal error that is inhibiting sending the invitation).

MORE INFORMATION

MailEnable SMTP Relay: http://www.mailenable.com/kb/content/article.asp?ID=ME020001

 



Product:MailEnable
Article:ME020682
Module:General
Keywords:
Class:BUG: Product Defect/Bug
Revised:Sunday, February 18, 2018
Author:
Publisher:MailEnable