Appointments synced with ActiveSync may not show correct timezone name


SYMPTOMS

When an appointment is created on ActiveSync and synced to another client, the timezone name may not be correct, although the offset is. This may happen for example, if you create the appointment Kuala Lumpur, Singapore timezone, but after syncing and editing to an Android device it then appears as Beijing timezone in Outlook.

CAUSE

This is caused by some ActiveSync clients (mostly from mobile devices) not sending the timezone name to the server, or sending a non-Windows timezone name. Since no recognised timezone name is sent to the server, just the offsets for the timezone, Microsoft Outlook tries a best guess, and will match the first timezone name that has the same offsets.

So for example, if you use the default calendar on an Android device to create an appointment in the Kuala Lumpur, Singapore timezone, the device only sends up to the server that the appointment is +8 hours UTC. When this is synced to Microsoft Outlook, Outlook will find the first timezone that is +8 hours UTC, which is the Beijing timezone. If you edit an appointment on an Android device, it will remove the timezone name, again causing the issue.

Microsoft Outlook on Android does send up the timezone name, but Android uses different timezone strings compared to Windows, so a match is not made. 

RESOLUTION

The timezone information will still be correct, but display a different name. Currently there is not a workaround for this issue.

 



Product:MailEnable
Article:ME020688
Module:General
Keywords:Android,activesync,timezone
Class:INF: Product Information
Revised:Monday, March 26, 2018
Author:
Publisher:MailEnable